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STEP for Adobe lllustrator

STEP for Adobe lllustrator is a component available as a plugin for Adobe lllustrator. Adobe lllustrator is frequently
used, for example, by product designers to make sketches of products, such as drawings of clothes and the details
that are needed for clothing production. STEP for Adobe lllustrator supports these designers in their work, as well
as any other users of lllustrator who need to store lllustrator files (.ai) and their associated artboards in STEP.

The STEP for Adobe lllustrator plugin integrates lllustrator directly with STEP. When saving an lllustrator file to
STEP from lllustrator, the artboards are automatically generated as .png image files and saved to a specified
classification folder in STEP along with the associated lllustrator file. The lllustrator file and artboards are also
automatically linked to the corresponding product or entity objectin STEP.

Note: Though STEP for Adobe lllustrator is optimized for use with the PLM solution—a special configuration of
STEP for the retail, footwear, and apparel (RFA) industries—this component can be installed on any STEP
system. For more information on PLM, contact see the PLM documentation.

Topics in this documentation explain how to:

« Configure lllustrator object types, asset reference types, System Settings, and the lllustrator component
model in the STEP Workbench

« Install the lllustrator Plugin and access STEP from within lllustrator
« Save lllustrator files to STEP and open lllustrator files saved to STEP from within lllustrator

To use this component, you must apply the STEP for Adobe lllustrator license and install the STEP for Adobe
lllustrator recipe. Contact your Stibo Systems representative to obtain the license and the latest install recipe.
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Configuring STEP for Adobe lllustrator in the
Workbench

Before using STEP for Adobe lllustrator, a number of configurations must first be performed in the STEP
Workbench. This topic explains how to:

« Create an asset object type for lllustrator files and an asset object type for lllustrator artboards

« Create the reference types used to link lllustrator files and artboards to products and/or entities

« Configure lllustrator settings under System Setup > Users & Groups

« Configure the lllustrator component model

Configuring lllustrator Object Types in the STEP Workbench

lllustrator File Asset Object type

If not already present on your system, create an lllustrator object type under Object Types & Structures > Assets.

This object type must have the MIME type of application/illustrator. Choose the Al icon Tito represent the
objecttypein the Tree.

For information on how to create an asset object type and add an icon, see the following topics in the Super User
Guide / System Setup / Super User Guide documentation:

o Creating an Object Type
o Object Type Icons

System Setup L 4 Illustrator File - Object Type
=& Object Types & Structures ~ || IEEEETEN | references || Log
T

rj Alternate Classifications

E} Assets
EEl'-- Agsets flame >| > [Value
..... Auto Classification Rule Set » D MlustratorFile
{7 BMP Image » MName Tlustrator File
----- Bulk Update Configuration

* Last edited by 2018-01-19 14:09:22 by USER4

----- D Business Rule Example

{3 CASS Certification Report
----- Configuration » [D Pattern
----- Export Manager Configuration > [con ;Eh

{3 GDSN Receiver CIN 5
N eceiver ample application ilustrator
-{7% GDSN Receiver X5D

* Mame Pattern

» MIME Types

{2 GDSN XSD
..... :} Imn
----- | Iustration

iﬂ Image Conversion Configuration

----ﬁ/

Dependencies

eference Target Lock Policy|  Strict

= yalid Attributes
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lllustrator Artboard Asset Object Type

This is the file type associated with the artboards that are saved to STEP along with lllustrator files. An artboard is
created for each individual artboard in the lllustrator document. This object type must have a MIME type of
image/png.

Note: A custom PNG icon is used in this example; you may use any icon you wish, or just use the generic system-
generated icon.

System Setup < Illustrator PNG - Object Type L
=-Z& Ohject Types & Structures A References || Log
9 Descript

rj Alternate Classifications

E} Assets |
> > >
EEl'-- Assets ame Value
..... Auto Classification Rul » D MustratorPNG
{7 BMP Image > Mame Hlustrator PNG
----- Bulk Update Configura

* Last edited by 2018-01-19 17:02: 26 by USER4

----- D Business Rule Example
{7 CASS Certification Rep ||| > Name Pattern
----- Configuration * ID Pattern

----- Export Manager Config s [eon

~{7% GDSN Receiver CIN 53
{7 GDSN Receiver XSD
(¥ GDSN XSD i i ndences
..... &= Icon

----- | Iustration
FEB Illustrator File

----- &

4

mage png

* MIME Types

Strict

lllustrator and Artboard Asset Reference Types

Two asset reference types must be created to link lllustrator files and artboards to a product or entity object. One of
these reference types must link lllustrator files to product or entity objects, and the second must link artboard
images to product or entity objects.

For instructions on how to create asset reference types in System Setup, see Creating a Reference Type in the
Super User Guide / System Setup / Super User Guide documentation.

Asset Reference Type for lllustrator Files

The asset reference type for lllustrator files must have 'No' selected for 'Allow multiple references,' since only one
lllustrator file is allowed to be referenced to each product/ entity.
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System Setup Illustrator Files - Reference Type
% Users & Groups L Validity || Log
' Description

[{IE\- Reference Types
[+ @ Product Reference Types

E}E Image and Document Reference T Hame 2| > [Value
..... *7] Board Asset Content > ID TlustratorFiles
----- &2 Brand Name Logo > MName Tustrator Files
----- = Entity To Artboards > Last edited by 2018-01-22 20:03:52.258 by USER 4
----- &2 Entity To Tlustrator
_____ ¥ GDSNFormat » Externally Maintained Mo
----- k2 GDSN Receiver CIN Sample * Dimension Dependencies
----- = GDSN Receiver Format > Completeness Score
----- &2 Tlustration )
..... ¥ ustrator Artboards * Wllow multiple references Mo
..... ] Tllustrator Files ___——-"'!'Mﬁﬁﬂagry Mo
----- B Installation Manual » Inheritance Mone
""" i MsDs * Completeness Score 11
----- & Owners Manual
----- & Part Mumber to Resource d - abe

This reference type must have a product and/or entity type as a valid source type and the lllustrator asset type as
the valid target type.

System Setup Illustrator Files - Validity

" Reference Type |RELLISN | Log
rﬁa Users & Groups ® T
EI--E.h Reference Types
B - -]
\I._a Product Reference Types - Name
= &) Image and Document Reference Ty » MustratorEntity Tlustrator Entity
----- E Tlustrator Files s Ttem Ttem
----- i Tlustrator Artboards > [Modify Source Types
----- ] Board Asset Content '?_ - -
----- B Brand Name Logo get I
----- 52 Entity To Artboards D * [Name :
..... &2 Entity To Hlustrator » MlustratorFile Tlustrator File
..... u GDSMFormat | * | Modify Target Types

Error Handling

If you configure your reference type incorrectly by selecting 'No' for 'Allow multiple references,’ this error message
will display when attempting to save an lllustrator file to STEP:
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Adobe llustrator

Error saving document to DB
Single reference violation for: com.stibo.core.domain.impl.FrontProductImplg

$Generated$$7: 107906, type: ProductTolllustrator

Asset Reference Type for Artboards

The asset reference type for lllustrator artboards must have 'Yes' selected for 'Allow multiple references,’ since
multiple artboards can appear in each lllustrator file.

System Setup Illustrator Artboards - Reference Type

-y Taos A || IEEEEERE N | validity || Log
o =

- Units
@ Users & Groups

EIBu‘ Reference Types Mame »| > |Value
[+ 4 Product Reference Types > D HustratorArtboards
= k2 Image and Document Reference T » Mame Tlustrator Arthoards
E :::,:: ::Sn: [L::;;Ee A > Last edited by 2018-01-22 20:02:33.0 by USER4
..... 2] Entity To Artboards * Externally Maintained Mo
""" =) Entity To Hustrator * Dimension Dependendes

----- =] GDSMFormat
----- %] GDSM Receiver CIN Sample

_____ %71 GDSN Receiver Format > |Allow multiple references fes
----- & Iustration > M Mo

» Completeness Score

Inheritance Maone
----- B Tlustrator Files
s o te g 1 3
----- &2 Installation Manual ompleteness Score
..... E MSDS > Purpose ab

This reference type must have a product and/or entity type as a valid source type and the artboard asset type (in
this example, ID = lllustratorPNG) as the valid target type.
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Illustrator Artboards - Validity

Reference Type [E]
% valid Source Types
D * [Mame »
* MustratorEntity Tlustrator Entity
* Ttem Ttem
| * |Modify Source Types
§ valid Target Types
1] > [Mame >
» MustratorPMNG Tlustrator PMG
| * |Modify Target Types

Workbench Configurations in System Setup

Additional configurations must be performed in System Setup to enable the STEP for Adobe lllustrator solution.
These configurations are set up under Users & Groups and within the lllustrator component model.

Users & Groups Settings

1. Navigate to System Setup > Users & Groups, then locate the lllustrator Settings flipper.

2. Click the ellipsis button (...]) in the Classification field to choose the classification folder where lllustrator files
and their associated artboards will be stored.

3. Clickinside the Context field and select a context from the dropdown. A context must be chosen from which to
display the product and/or entity names in the STEP panelin lllustrator.

System Setup < System Settings =

iﬁ‘ Object Types & Structures & | | BEERZNETZGO0EN | Log

H-L5) Tags

: i ’ = Administrative Tasks

- Units

%, Disers 8 Groups | =ty | © flustrator Settings

Reference Types Mame s alue N
; Waorkspa

: ar =S » Classification Tustrator Files (TlustratorFiles)

Table

BB Keys > Context English US

lllustrator Component Model

The lllustrator component model has three fields: Object Types, lllustrator Artboards Reference Type, and
lllustrator File Reference Type. To configure the component model, follow these steps.

1. Navigate to System Setup > Component Models > lllustrator, then click the 'Edit" hyperlink.
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System Setup Illustrator - Component Model Configuration
--Address Component Model
-Auto Classification Model
~Country Aliases
-External Stored Assets Model

Mame #| * alue » Description >

The Object Types that can have Illustrator
assets

The Reference Type used to link objects with
~GDSN Provider model Tlustrator Artboards. The Reference Type
-GDSM Receiver model must have an Object Type with the Mime

- Google Shopping Madel Type “imagefpng” as a valid target type

The Reference Type used to link objects with
the Illustrator File. The Reference Type must
have an Object Type with the Mime Type
"application/filustrator” as a valid target type

W

Ohject Types

W

Tlustrator Artboards Reference Type E,.

W

o

Tlustrator File Reference Type

--Matching - Link Golden Reco
-Matching - Merge Golden Record

Edit

2. Inthe'Edit Component Model Configuration' dialog, click the + icon in the 'Object Types' field to choose the
object types that lllustrator files can be referenced by.

33 Edit Component Medel Configuration

* [Name Value » | » |Description >

» | 3€ | Object Types The Object Types that can have Ilustrator assets
The Reference Type used to link objects with Ilustrator

» x Ilustrator Artboards Reference Type + Artboards, The Reference Type must have an Object Type with
the Mime Type “image/png” as a valid target type
The Reference Type used to link objects with the Ilustrator

> x Ilustrator File Reference Type + File. The Reference Type must have an Object Type with the
Mime Type “application/fillustrator”™ as a valid target type

Save Restore live settings Save pending Cancel

3. Inthe'Select object types for aspect' dialog that displays, choose the product and/or entity object types that
can be referenced to lllustrator files.

Note: Though all object types appear in the dialog, lllustrator files can only be linked to products and entities.
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| Search

-] Alternate Classifications
4403 Assets

[ Entity user-type root

r_=| Primary Product Classification
+-1z Product-Overrides

-3 Publication group types

- Detailz

Select Cancel

4. Click the + iconin the 'lllustrator Artboards Reference Type' field to choose the reference type that will be used
to link Illustrator artboard files (.png) to the designated product and/or entity object types. Only one reference
type can be selected.

5. Clickthe +iconin the 'lllustrator File Reference type' field to choose the reference type that will be used to link
lllustrator files (.ai) to the designated product and/or entity object types. Only one reference type can be
selected.

6. The configured component model should now resemble the following. Click Save to close the dialog and
complete the configuration.

$2 Edit Component Model Configuration

* [Name * | » |Value * | » |Description >
_ Tlustrator Entity > The Object Types that can have Ilustrator
» |y | Object Types + [ xassets
Ttem

E‘he Reference Type used to link objects with
llustrator Artboards. The Reference Type
» |/ |Tlustrator Artboards Reference Type |+ Bl Tustrator Artboards [ ust have an Object Type with the Mime
pre “imagefpng” as a valid target type
I;:le Reference Type used to link objects with
e Hlustrator File, The Reference Type must
ave an Object Type with the Mime Type
pplication/fillustrator” as a valid target type

¢ | | Illustrator File Reference Type + B, Mlustrator Files P

Restore live settings Save pending Cancel
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Accessing STEP from Adobe lllustrator

This topic explains how to install the STEP plugin for Adobe lllustrator on your local computer and how to log on to
STEP from within lllustrator. This topic assumes the following:

« You have Adobe lllustrator installed on your computer (supported version is CC 2017)

« You have been assigned a STEP user name and password

« You have installed the STEP Adobe lllustrator component on your STEP system

Installing the lllustrator Plugin

To log onto STEP from within Illustrator, you must first install the STEP lllustrator plugin that is associated with the
STEP system that you are trying to access.

Note: Itis strongly recommended that lllustrator is closed while you install the plugin. If lllustrator is open when
you install the plugin, you will need to close and reopen lllustrator before the plugin can be registered.

The following instructions are written for the Windows platform, but the overall process of downloading and
installing the plugin is equivalent for Mac users.

1. Inyour browser, navigate to the Start Page for your STEP system and locate the 'STEP for Adobe lllustrator’
icon at the bottom of the screen.

STEP for Adobe Illustrator

2. Click on the icon to display the supported plugins for your STEP system.

Mac: Adobe lllustrator CC-2017 (CC12) Windows: Adobe Illustrator CC-2017
[CC12)

3. Select the plugin that matches the version and platform of lllustrator that you are running. For Windows users,
the plugin is contained within a .ZIP file. For Mac users, the plugin is contained within a .dmg file. The file should
download automatically, though the file may download differently depending on your browser settings. The
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following screenshot shows how the downloaded .ZIP file appears at the bottom of a browser window in
Chrome.

3

illustrator_step-illu...zip Show all X

4. Locate the .ZIP file in its download location (such as your Downloads folder or other default download
location), then move it into your Adobe lllustrator Plug-Ins folder. For Windows platforms, the file path format
is as follows. ("Adobe lllustrator CC 2017' will be replaced with the specific version of InDesign that you are
using.)

C:\Program Files\Adobe\Adobe lllustrator CC 2017\Plug-Ins

5. Unzip the file directly into the Plug-Ins folder. Optionally, you can create your own folder within the Plug-Ins
folder to store the STEP lllustrator plugin (for example, 'STEPplugins'), but this is not required.

6. Once unzipped, your Plug-Ins folder should resemble the following. The ZIP file may be deleted at this point,
though it is not required to do so.

= v A <« O5Disk (C:) » Program Files » Adobe » Adobe lllustrator CC 2017+ Plug-ins »
Mame Date modified Type Size
Bxtensions 1/19/2018 9:49 AM File folder
[Mlustrator Filters 1/19/2018 9:49 AM File folder
[llustrator Formats 171972018 9:49 AM File folder
[Mlustrator U 1/19/2018 9:48 AM File folder
illustrator_step-illustratorwin,cc2017 171972018 11:59 AM File folder
Photoshop Filters 1/19/2018 9:49 AM File folder
Photoshop Formats 171972018 9:49 AM File folder
Text Filters 1/18/2018 9:49 AM File folder
Tools 1/19/2018 9:49 AM File folder
illustrator_step-illustratorwin.cc2017.zip | 1/19/2012 11:52 AM Compressed (zipped)... 1297 K
7. The contents of the unzipped file will look as follows:
« v P <« fAdobe lllustrator CC 2017 » Plug-ins » illustrator_step-illustrator.win.cc2017
Mame Date modified Type Size
ﬂ step-illustrator.win.cc2017.aip 118/201812:04 PM - Adobe lllustrator ... 3173 KB

Accessing STEP From lllustrator

After installing the plugin, follow these steps to access STEP from lllustrator by using the STEP panel.
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1. Open your lllustrator client, then navigate to Window > STEP to open the STEP panel.

2. Onthe STEP panel, enter your STEP user name, password, and the address of your STEP instance (e.g.
user-dev), then click Login.

3. The STEP panel now displays two options—Open from STEP and Save to STEP.

Open from STEP

Save to STEP

4. Click Open from STEP if there is an lllustrator file already saved to STEP that you would like to open.
Otherwise, activate Save to STEP by opening a locally saved lllustrator file.

Go to the next topic in this documentation section, Saving and Opening lllustrator Files Using the STEP
Panel, for instructions on how to save lllustrator files to STEP and open lllustrator files from STEP.
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Opening and Saving lllustrator Files With the STEP
Panel

The STEP panel is used to both open lllustrator files from STEP and save lllustrator files to STEP. Using the
STEP panel allows designers to save lllustrator documents to STEP without needing to use the STEP
Workbench, allowing them to work exclusively in lllustrator.

Note: To save or open lllustrator files using the STEP panel, you must first know either the STEP name or STEP
ID of the product or entity that is associated with the lllustrator file. There is no browse feature on the STEP panel;
only typeahead search.

Opening lllustrator Files From STEP

1. Click Open from STEP on the STEP Panel, then type either the STEP Name or ID of the product (or entity)
associated with the lllustrator file into the typeahead search field.

Note: lllustrator files themselves cannot be searched from the STEP panel; only their associated products or
entities.

2. Select the product/ entity in the STEP panel, then double-click to open the lllustrator file.

Spring Tees

Summer Tees
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Saving lllustrator Files to STEP

For this example, the lllustrator file will be saved to a product object in STEP with the name 'Spring Tees' and the
STEP ID of 107906.

1. In Adobe lllustrator, open the lllustrator file that you would like to save to STEP. If already saved to STEP,
follow the instructions in the first section of this topic. If not already saved to STEP, open the file from your local
drive. In this example, a file named 'Spring Tees' with three artboards is used.

Spring Tees.ai @ 25% (CMYK/GPU Preview] X

2. Openthe STEP panel and click Save to STEP.

3. Inthe'Save to...' field, start typing either the STEP ID or STEP name of the product or entity object to which
you want to save the file.

4. Once the product or entity appears in the panel, select and double click it.
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% STEP

£~  Save

Sp ri

E Spring Tees

5. Ifthe save is successful, the STEP panel displays the ID of the product with a thumbnail of the first artboard
associated with the lllustrator file.

Save to STEP

Open from STEP

Opened file

E Spring Tees

Resaving and Overwriting lllustrator Files and Artboards

Once the lllustrator file is saved to STEP, a 'Save' link displays next to the file thumbnail in the STEP panel. Using
this link makes it easier to resave the document to STEP after making edits, allowing you to overwrite the previous
file and associated artboards without having to search for the associated product or entity again.
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Save to STEP

Open from STEP

Opened file

B Spring Tees

Viewing lllustrator Files in the STEP Workbench

References Tab

After an lllustrator file is saved to STEP, you can view the referenced lllustrator file and artboards by navigating to
the relevant product or entity in the workbench and clicking on the References tab. The lllustrator file and
associated artboards will be linked to the product / entity using the asset reference types that were chosen when
configuring the lllustrator component model.

Tree Spring Tees rev.0.1 - References
~{[] TD_TecDoc Manufacturer Root L Commercial | Tables || Category Profile || Proof View Skake
""%TD—TEU:]“C Resource Root | Praduct " Sub Products ] References Referenced By In

[+-[&l Publications
[=-[[T] Primary Product Hierarchy § Ungrouy e & 2
[ Discontinued Products Reference Type v| » [Target *|?
i Packaging * |Brand Name Logo + (g
E Product Overrides > | Ilstration Y
=11 Products ;
EJF_=| Product Concepts H @4 Spring Tees_01-Artboard 1 |7
: E”j Apparel * |Tlustrator Artboards + i 24 Spring Tees_02-Artboard 2 |
E|r_=| T-Shirts & (@4 Spring Tees_03-Artboard 3 |4
(m £85 » |Tlustrator Files & ] Spring Tees Y
E Summer Tees =
5] Alarms R L U e T
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Classification Folder

Navigate to the classification node that was specified under 'lllustrator Settings' in Users & Groups. This is the
location where all lllustrator files and associated artboards will be saved.

Note: All lllustrator files will be saved in this folder, whether they are linked to products or entities, and even if they
are linked to both types of objects.

Tree Spring Tees rev.3.0 - Images & Documents

([ Assets Wil Images & Documents |EEEERE | Referenced By || Status || State Log || Taske
#-{2] AutoCare Reference Data
r_=| Configurations
=) Tlustrator Files Mame | > |Value *
7] Spring Tees > ID 107916
>ﬁ Spring Tees_01-Artboard 1 > Name Spring Tees
ﬁ Spring Tees_02-Artboard 2 : :
ﬁ Spring Tees_03-Arthoard 3 * Object Type Tustrator File
-] Index Words > Revision 3.0 Last edited by USER4 on Ma. ..
g TEd]ﬂC_ﬁ.S;:tS_Rﬂﬂt > Approved 3€ Never Been Approved
(-] TecDoc Reference Data
* [Translati Mot Translated
-] {TD_TecDoc Manufacturer Root) ransiation ot Transia
[ (TD_TecDoc Resource Roat) » Path Classification 1 root/Illustrator Fi...

Revision Control

lllustrator files remain under revision control in the workbench so users can revert back to an earlier revision if , for
example, someone accidentally saves back a file with incorrect edits. These revisions can be viewed by selecting
the Status tab when the lllustrator file is selected in the tree. Artboards are, however, not under revision control,
so when reverting to an earlier revision of the lllustrator file, the artboards from the latest revision remain, causing
them to be out of sync. New artboards will be created when the document is re-saved to STEP.

TShirtDesigns rev.2.0 - Status

Images&Documents ReFmencesl Referenced By @ State Log || Tasks

Edited

W

Revision  * |Created > Major  * [User » (Comment >

* |0

Mon Jan 22 00:59:37 EST ...

Mon Jan 22 00:59:37 EST ...

®

LISER4

Auto Generated

* (L0

Man Jan 22 00:34:58 EST ...

Mon Jan 22 00:33:58 EST ...

®

LISER4
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