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Bulk Updates
Bulk update is an efficient way of updatingmultiple objects in a single operation, and it is available on themajority
of objects in Tree or SystemSetup that have an editor.

A user can run the bulk update process on a collection, a search result, or objects in tree or system setup. It is also
possible to select multiple objects and run a bulk update on all selected objects. See theRunning Bulk Updates
topic within theBulk Updates documentation for more information.
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Running Bulk Updates
The bulk update functionality allows a user to easily update large amounts of objects in a single operation.

There are three possible ways to run a Bulk Update:

1. It can be run on all objects in a single collection or multiple collections. To do so, right-click the relevant
collection(s) in Tree and chooseRun Bulk Update.

2. It can be run on a single or multiple selected objects in Tree or SystemSetup. To do so go to File > Bulk Update
> Run Bulk Update.
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Objects that it can be run on in Tree are: 

l Assets

l Classifications

l Collections

l Configurations

l eCatalogues

l Entities

l IndexWords

l Products

l Publications
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Objects that it can be run on in System Setup are:

l Attributes

l Attribute Transformations

l Asset Importer

l Change Packages

l CompletenessMetrics

l Event Processors

l Event Queues

l GatewayEndpoints

l GDSN- Data pool- Receiver or publisher

l Global BusinessRules (actions, conditions, and libraries)

l Inbound Integration Endpoints

l Keys

l List of Values

l Match Codes andMatching Algorithms

l Outbound Integration Endpoints

l Tables

l Tags

l Units

l Users andGroups

l WebUIs

l Workflows

l Workflow Profiles

l Reference types / link types

l Object type & structures (asset, classification, publication, setup group, etc.)

l Context -Dimension points

3. Lastly, it can be run on search results. To do so, perform a search and then click on theBulk Update button,

, at the bottom of theSearch pane.
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For more on how to perform searches using the Search tab in STEPWorkbench, see theSearch Overview topic
in theGetting Started / User Guide documentation.

After selecting one of the three options above to run a bulk update, the Bulk Update wizard will appear. Steps for
navigating through the Bulk Update wizard are described in theBulk Update Wizard in theBulk Updates
documentation.

Bulk Update Wizard
The Bulk Update wizard guides a user through the bulk update process, and ensures all necessary settings and
data is provided to run the bulk update.

Step 1 - Configuration
In step 1, specify whether an existing configuration should be run for the bulk update, or if a new configuration
should be created.

If a user has a saved bulk update configuration they can click the ellipsis button (…) to select the relevant
configuration. Otherwise, selectCreate New Configuration, and clickNext.
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Step 2 - Operations
In step 2, specify the operations needed for the bulk update to perform. If an existing configuration was selected,
all operations are listed in the order they are carried out.

If an operation is not already present, select from the dropdownmenu the operations that should be applied to the
set of objects.

The selected operation dictates what elements need to be filled out. The required elements vary from operation to
operation. For a detailed description of the operations, see theBulk Update Operations topic within theBulk
Update documentation.

More than one operation can be applied to a bulk update by selecting 'AddOperation'. To change the order of the
operations applied to the update, use the up and down arrows . An operation can be deleted by clicking the .
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Important: Ensure that the operations are listed in the order that they are needed to perform. Operations are
performed from the top down. Thismeans that operations further down the list overwrite operations further up.
This includeswhenmore than one operation is specified. The operations still are applied in the listed order. If one
operation fails for an object (ex: due to validation base typemismatch), all changes to the object will be rolled back
and the object will be left as if was prior to applying the Bulk Update.

Step 3 - Preview
This screen shows examples of the results of the update. It displays amaximumof 10 objects. For each object the
existing data and how the data will look after the update is applied displays.

The preview also displayswarnings and errors if an operation that a user has chosen is not applicable. If a user
hovers the cursor over the icons, they can see the error or warning text.
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Click theBack button to change an operation or parameter. When satisfied with the preview, clickNext to
continue.

Step 4 - Advanced
In the final step, select one or more options, some of which can be selected simultaneously.

l SelectingDo not run now allows the user to run the bulk update later, and not immediately when the wizard is
finished.When selecting this option, a user can still save the configuration, butAuto Approve andPre-flight
are disabled.

l SelectingAuto Approve approves the objects automatically after the update, and then places the objects in
the approved workspace.

l SelectingPre-flight allows a user to perform a test run of the update. When the user clicks 'Finish', the test runs
in the background. This will apply the operations selected, and then roll them back. Additionally an execution
report and an Impact Report will be generated. Temporary collectionswill also be created for the objects where
the operationswere successfully applied, and for the oneswere errors were generated. The availability of this
option depends on the user's system setup.

Note: It is recommended to always run a Pre-flight test or to try applying operations to a small set of objects
before large quantities of objects are updated, as there is no 'undo' functionality for bulk updates.

l SelectingSave configuration allows a user to save the configuration so that it can be used again.
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l In theProcess Description field a user can write in a name that displays for the background process.
l TheAvailable for object types limits the object types and nodes affected by the bulk update operations. First
select an object type from the dropdown, then click the ellipsis button (…) to select the nodes to update.
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l ClickFinish to complete the bulk update configuration and start the operation(s) in a background process.

For more onmonitoring bulk updates through a background process, see theMonitoring Bulk Updates topic in
this documentation.
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Bulk Update Operations
There are a number of operation options available when performing a bulk update. Becausemore than one
operation type can be applied during a bulk update, and the order in which the operations are listedmatter when
performing a bulk update, it is important to fully understand what each operation does.

Note: Ensure that the operations are listed in the order that they are needed to perform. Operations are
performed from the top down. Thismeans that operations further down the list overwrite operations further up.

The following sections contain explanations of each operation type available in the Bulk Update wizard.

l Attribute values

l Data Containers

l Data Quality

l Publishing

l References and Links

l Workflow

l Run BusinessRule

l SendRepublish Event

l Set Name

l Set Object Type

Operations are can be chosen in the Operations step of the Bulk Update wizard.
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See theRunning Bulk Updates topic within theBulk Update documentation for more information on the Bulk
Update wizard.

For some of the operations, a user can specify a function in the Function editor. See theUsing Function Editor
topic within theAttributes documentation for more information on writing functions.

Attribute Values Operations for Bulk Updates
The following operations allow you tomodify attribute values.

Merge Attribute Values
Copies the values from the first selected attribute to the other, in the current workspace, based on the parameter
settings. For dimension dependent attributes, the copy is performed across all dimensions or applicable
combinations of dimensions.

Verifying Attributes for Merge
This operation can also be started fromSystemSetup by selecting an attribute, then right-click and select Merge
Attribute Values. For details about verifying the attributes before performing this operation, see theMerging
Attribute Values section of theSystem Setup / Super User Guide.

Tomerge attribute values for only some objects, go to theSearch tab, and create Search Results of the objects to
merge. Then either click theCollections button to save the results as a collection (which can be used for repeated
updates), or click theBulk Update button and clickNext to display the Operations page and the followingMerge
Attribute Values parameters.
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Merge Attribute Values Operation

1. In theMerge parameter, click the ellipsis button (…) to display the Select Attribute dialog, choose the attribute
to copy values from, and click theSelect button.

2. In the into parameter, click the ellipsis button (…) to display the Select Attribute dialog, choose the attribute to
copy values to, and click theSelect button.

3. For theSource Workspace field, use the dropdown to select the workspace that holds the values to be copied
to the target, based on the other parameters. Values are always pasted into theMain workspace.

Consider the following example data, and assumewewill choose to Overwrite existing values (as described
below). Selecting the SourceWorkspace = Main will result in writing the T-shirt Size value of S, while selecting
SourceWorkspace = Approved will write the XS value.

4. For theOverwrite field, choose an option to determine when to write to the target attribute. Validation errors
are displayed on the Preview page when a value cannot bemodified.

Consider the following data and the effects of the options as shown in the Preview images below. 'T-shirt Size'
is the source attribute and 'Size' is the target attribute:
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l Keep original valuesmeans the source value is only copied to the target attribute when the target attribute
is blank. If the target attribute contains a value, the target value is not changed. Notice that the only value
changed in this scenario is for object 18212 L B, since the source object had a value and the target value was
blank. Since the other objects either had values for the target or the source was blank, none of themwere
modified.

l Overwrite existing valuesmeans the source value overwrites the target value, except when the source
attribute is blank. If the source attribute is blank, the target value is not changed. Notice that two values
changed in this scenario: object 18210MB had its value overwritten since a value existed for the source, and
object 18212 L B was overwritten since the source object had a value and the target value was blank.
Objects 18213MOand 18216 LOboth had blank source values, so the target valueswere not overwritten.
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5. ForMerge Link Attributes field, if the selected attributes are both used as an attribute on a reference, a
product classification link, or an attribute link, merging of those values are based on the Yes or No set in this
parameter, as well as the other parameters on the operation. This option is not relevant when values do not
exist on references for the selected attributes.

For example, consider the following values for the attributes 'Qty of Next Lower Package' and 'Qty of Next
Higher Package' on the Case to Child reference.

Setting the operation parameters as 'Qty of Next Lower Package' for the source, 'Qty of Next Higher Package'
for the target, using theOverwrite existing values, and settingMerge Link Attribute = Yes results in this preview
of resulting values:

For more information about attributes on references, see theProduct Attribute Link Type section of the
System Setup / Super User Guide documentation.

Note: TheMerge Attribute Values operation does not delete any attributes, it can only update values. If desired,
manually delete the source attribute once you confirm themerged data.

Set Value
Sets the value of the selected attribute based on a value enteredmanually or via a function.

Manual Values
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1. Click the ellipsis button (…) on the first field and select the attribute that will be updated.

Note: The selected attribute dictates the label on themanual button. In the image below, the selected attribute
requires a text value and so the label is 'abc.' If the selected attribute is numeric, '123' is displayed, and so on
for each validation base type.

2. Since themanual value button is selected by default, enter the desired value in the '=' field. The value of the
selected attribute will be set equal to thismanual value.

Function Values
1. Click the ellipsis button (…) on the first field and select the attribute that will be updated.
2. Click the 'fx' button to indicate a function will be used.

3. Click the ellipsis button (…) on the '=' field to display the function editor.
4. Enter a function based on the requirements that will resolve to the desired value.

See theUsing Function Editor topic within theAttributes documentation for more information on writing
functions.
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Data Containers Operations for Bulk Updates
The options for Data Containers operations are below:

Update Data Containers
This operation allows users to run business actions on selected data container objects. When executing this
operation, users can filter which data container objects to work with by specifying a business condition and/or data
container type, before running the specified business action on those objects.

1. Run a search for data containers based on the desired criteria, and run the bulk update by clicking the Bulk
Update icon.

2. On the 'Operations' step of the wizard, clickAdd Operation, and select Data Containers > Update Data
Containers.

3. In theData Container Type parameter, click the ellipsis button (…) and select the data container type this
operation should apply to. This is an optional selection.

4. In theBusiness Condition parameter, click the ellipsis button (…) and select a business condition to filter
eligible data container objects further. This is an optional selection.

5. In theBusiness Action parameter, click the ellipsis button (…) and select a business action to apply to the
data container objects upon execution of the bulk update. This is a required parameter.

Data Quality Operations for Bulk Updates
The options for Data Quality operations are below:

Generate Match Codes
For this operation, a user needs to select whichmatch code to use. Once selected, it will then generatematch
code values for the selected objects of the bulk update.

Note: Collection objects shouldmatch to thematch code object type and category.
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For more onmatch codes and how to create them see theConfiguring Match Codes topic in theMatching and
Linking documentation.

Match Duplicates (apply matching algorithm)
DEPRECATED. Suggested to instead use 'Send Republish Event' to Event Processor configured to apply
matching using user'smatching algorithm.

User will have to select whichMatching Algorithm to use.

Will then apply thematching algorithm on selected objects of this bulk update—this includes generating a list of
possible duplicates and a score that indicates how identical the objects are. And if a golden recordmatching
algorithm is used it will also update golden record linkages and re-apply survivorship rules.

Standardize Address
This operation allows for different standardization actions to be taken on addresses by using the Loqate solution. If
applicable, CASS (Coding Accuracy Support System) operations can also be performed to apply a stricter level of
address validation to US-based addresses.

Standardize Address bulk update operations are valid for execution on entities with flat attributes, e.g. Address
object types and addressData Containers (Data Containers with address attributes).

This documentation topic describes the options available when configuring a Standardize Address bulk update
operation. For more detailed information on the overall Loqate and CASS solutions, see the Loqate Integration
section of theData Integration documentation.

Prerequisites
Before a Standardize Address bulk update operation can be run, the following conditionsmust bemet:
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l Usersmust be connected to a Loqate server, either through a cloud API or local API

l The AddressComponent Model must already be configured. It is strongly recommended to configure this
component model using the 'Easy setup of AddressComponent Model' wizard. For more information, see the
Address Component Model section of the Loqate documentation.

l To view and use the CASS features, usersmust:

l Purchase a CASS license

l Be connected to Loqate through a localAPI (CASS components will not work with a Loqate Cloud
API)

l Be based in the US, asCASS is not valid outside of the US

l Configure the CASS AddressComponent Model. For more information, see theCASS Address
Component Model topic in the Loqate documentation.

Address Standardization Modes
Three options are available from the Address StandardizationMode dropdown list.

l Overwrite Existing Standardized Address:Overwrites an existing standardized address bymaking a call to
Loqate, which returns the latest standardized address and overwrites the existing one.

l Generate Hash Value Only:When this option is chosen, the business action will recalculate the 'Validation
Hash' value without making a call to Loqate. The hash value is based on the address input fields only and is
calculated andmaintained by STEP.

This option is used in caseswhen pre-standardized addresses, which are known to be correct, are imported.
Because the addresses are new, no hash value is present. When the 'Generate Hash Value only' action is run,
STEP generates a hash value and places it into the 'Validation Hash' field. The hash value lets STEP know that
the addresses are new, ensuring that they are not picked up and restandardized by STEP shortly after they are
imported. For users of the Loqate Cloud API solution, this savesmoney by avoiding unnecessary calls to
Loqate, since users are charged a fee for every call made to Loqate.
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l Disable Address Standardization: This option is primarily useful for users who import addresses in bulk,
either manually or by using an inbound integration. If a business rule is in place that runs a Standardize Address
bulk update on import, then selecting 'Disable Address Standardization' is a simple way to temporarily turn off
automatic address validation on import. This allows users to validate the addresses later.

Renew Address Validations
The checkbox optionRenew address validations older than allows for addresses older than a designated
number of days to be revalidated. This is useful in case an addresswas validated an extended period of time ago
and the addressmay no longer be valid. The default number of days is 160. The field is disabled by entering the
value '0.'

STEP determines the age of an address by the value present in the 'Validation Time' field.

Important: For users of the Loqate Cloud installation, care should be exercised when using this functionality.
Since all addresses older than the specified time period will be revalidated, each additional validation will make a
chargeable call to Loqate.

CASS Validation
TwoCASS address validation options are available on the Standardize Address dialog.
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l Turn on CASS validation for US addresses: If checked, all addresses are sent for standardization to the
Loqate Local server integration and also validated against CASS data.

l CASS Certification Report Event Processor: If you would also like a CASS certification report generated
after using CASS validation on an address, click the ellipsis button (…) and select the relevant CASS
certification report event processor from the 'Select Event Processor' dialog. For more information, see the
CASS Certification Report Processing Plugin Parameters and Triggers section of theEvent
Processors documentation.

Publishing Operations for Bulk Updates
Several bulk update operations are available for publications in STEP.

Bulk update operations for publications can be accessed either by selecting File > Bulk Update > Run Bulk
Update, or by right-clicking on a publication group object, publication object (pictured in the below screenshot),
section object, or DTP document in the publication hierarchy and selectingRun Bulk Update.
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Once the Bulk Update wizard is launched, the publishing options are accessed in step 2 of the Bulk Update wizard
(Operations) by selecting 'Publishing' from the operations dropdownmenu.
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Start flatplans in STEP Workflow
Adds all Flatplanner spreads (planned pages) in the selected publication group, publication, or section into the
specified Flatplanner workflow. The bulk update is initiated by right-clicking on the desired publication group,
publication, or section. A selection of planned pages can also be chosen for bulk initiation into a Flatplanner
workflow bymulti-selecting them and going to File > Bulk Update > Run Bulk Update.

The desired workflow is chosen from the 'Workflow' dropdown list. Note that only workflows valid for planned
pageswill appear. Flatplans that are already in a workflow are not affected.

After selecting which workflow to initiate the Flatplans into, a 'ProcessNote' can be entered to name the resultant
background process.

Remove flatplans from STEP Workflow
This option is legacy functionality (pre-STEP 8.0) fromwhen only one workflow at a time was allowed for planned
pages. There is no ability to select a specified workflow.
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A 'ProcessNote' can be entered to name the background process that takes place.

Check publication document for needs update
This checks all actual pages saved to the selected publication / section to determine if updates are needed. A page
will need an update if any elementsmounted on the page (for example, attribute values or image references) have
changed in STEP since the page was originally saved to STEP.

Checking documents for updates is only useful for AutoPage and Flatplanner publications. Since near-identical
functionality can be accessed from other locations in the workbench (including right-clicking on a publication or
section object in the Tree and clicking 'Check for update needed...'), the use cases and applications for checking
documents for updates are detailed in the following publishing-specific topics instead:

l Updating Documents in AutoPage in theSTEP AutoPage documentation
l Updating Documents in Flatplanner in theSTEP Flatplanner documentation

Update publication document
When updating a publication document there are two options to choose from:

1. Update all contents of section: This updates all information on all actual pages saved to the selected
publication, section, or DTP document.

2. Update only the following items of the selection: Choosing this allows for the selection of specific items to
be updated on the actual pages, such as attributes, image references, and table types.
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The 'Update publication document' bulk update option functions almost identically to theUpdate feature that is
directly accessed by right-clicking on publication, section, or DTP document objects in the Tree. The selections in
the 'Operations' dialog pictured above are identical to those in the 'Update contents of documents' dialog that is
accessed through the 'Update' feature. Because of these similarities—and because the 'Update' feature ismore
commonly used than the bulk update feature to update documents—this feature is detailed in the STEP'n'design
documentation instead. SeeUpdating Documents From the Workbench in theSTEP'n'design
documentation for more information.

References and Links Operations for Bulk Updates
Bellow are all options for adding references and links:

Add Attribute Link
When choosing this object, the selected attribute will be linked to the collection of valid objects.
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If an attribute is on an object, it is also viewable by going to the References tab on the object, and selecting the
flipper 'Linked Attributes fromProduct Hierarchy'. If there is an attribute that does not have an edible field (or link)
to store data, choosing this option adds a link to an attribute, and allows data to be stored.

For more information on linked attributes see theAttribute Links topic in theSystem Setup / Super User
Guide documentation.

Add Reference or Add Reference By
Add Reference andAdd Reference By both have similar configurations for bulk updates. Performing this action
forAdd Reference adds a reference of a specified type to a target. Alternatively, forAdd Reference By this
adds a reference from a target to the source. It is important that the objects that are to receive the reference are
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selected before the bulk update is run.

First, select a reference type, and then choose a target (object) or Source that is in accordance with the selected
type.

When finished, a user should see the added type reference to the target. An example usingAdd Reference is
below:

Similarly, a user could specify a function in the function editor by selecting the 'fx' button and clicking the ellipsis
buttons to bring up the editor.

Again, an example usingAdd Reference is below though it works the sameway forAdd Reference By:

After selecting the 'Type' of reference, a user opens the function editor and types in the function needed. In this
case there is an attribute on the item called 'Product Image' that holds the ID of an image asset.
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When the bulk update is run, it uses the ID in the attribute to call forth which asset to put on the Primary Product
Image reference.

Automatic Classification
Classifies the selected objects automatically according to a set of rules. To perform this operation, a user selects
the following:

l A rule set which is selected using the ellipsis button.

l The context in which the rule conditions should be evaluated.

l If 'Use approved rule set' is checked, then only approved rule sets can be used for this operation.

SeeAutomatic Classification documentation for more information.
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Industry Classification Synchronization
This operation allows users to reclassify products to newer eCl@ss, ETIM, or UNSPSC versions.When
executing this operation the specified product to classification link type will be overwritten with the new version of
the classification hierarchy for all updated products.

1. Run a search for any products that need their classification links updated to a newer eCl@ss, ETIM, or
UNSPSC classification hierarchy, and run the bulk update by clicking the Bulk Update icon.

2. On the 'Operations' step of the wizard, clickAdd Operation and select References and Links > Industry
Classification Synchronization.

3. In the Industry standard matcher parameter, select the relevant industry standard from the dropdown list.

4. In theSource classification root parameter, click the ellipsis button (…) and select the classification root
node for the original industry classification version.

5. In the Target classification root parameter, click the ellipsis button (…) and select the classification root
node for the new industry classification version.

6. In theProduct to classification link type parameter, click the ellipsis button (…) and select the product to
classification link type the products use to link into the classification hierarchy.

Link Asset to Classification
This allows users to link assets to a specified classification.

1. Select the assets that need to be linked, and run the bulk update by going to File > Bulk Update > Run Bulk
Update

2. In theWizard select References and Links > Link Asset to Classification

3. Select the classification the asset should be linked to and run the bulk update.
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4. Assets should now appear under designated classification folder.

For more information on how to use the function editor option, 'fx', please see theUsing Function Editor topic in
theSystem Setup / Super User Guide documentation.

Remove Attribute Link
This option removes the selected link to an attribute. Note that the selected object should have a direct link to the
attribute.
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Select the attribute that is to be removed by clicking the ellipsis button, and run the bulk update.
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Remove Reference
This removes references to a specific target or all references of a specific type.

To remove all references of a specific type select the reference type, and then check 'Remove All'.

To remove references of a specific target select a reference type, and then select the target.

This can also be done by specifying a function in the function editor. For more information on how to use the
function editor option, 'fx', please see the Function Editor topic in theSystem Setup documentation.

After selecting the 'Type' of reference, a user opens the function editor and types in the function needed. In this
example there is an attribute on the item called 'Product Image' that holds the ID of an image asset.
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When the bulk update is run, it uses the ID in the attribute to call forth which reference to remove from the Product
Image reference.
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Set Product to Classification Link Type
This assigns a new object type and a classification link type to the selected classifications. To do this a new object
type needs to be selected first, and then the relevant classification link type needs to be selected.

It is important to note that the object types needs to bemade valid for the classification type.
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Once validity is checked, a user can choose a new Object type and a new Link Type. As seen in the example
below, the items under theWebHierarchyRoot with theWebsite Link are now going to be of the object type
'Merchandising HierarchyRoot' with theMerchandisingLink type.

Unlink Asset from Classification
Selected assets will be unlinked from specified classification. A user needs to select the classification using the
ellipsis button where the assets are to be unlinked.
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This can also be done by specifying a function in the function editor by clicking the 'fx' button. For more information
on how to use the function editor option, 'fx', please see the Function Editor topic in theSystem Setup
documentation.

A user opens the function editor, and types in the function needed. In this example there is an attribute on the item
"BlueTruckIcon" called 'Asset Keywords' that holds the ID of the Illustrations classifications folder. The user in this
case no longer wants 'BlueTruckIcon' to be in the Illustrations classification folder.

If the user wishes to remove this Asset from the Illustrations folder using the 'fx' function, theywould need to type in
the ID of the attribute that holds the value that theywant to get rid of. In this caseProdval("Asset Keywords").

Once completed, the asset is no loner linked to the Illustrations classification folder.
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Workflow Operations for Bulk Updates
The following options are actions that take place with workflows:

Claim
Workflow tasks are assigned to user groupswhere individual users in those groups can then claim the task for
themselves from the group. As a user, to claim a number of tasks at once, select a workflow from the dropdown
menu and then select the required state from the dropdown list.

For more information on claiming bulk updates in workflows see theBulk Update Operations for Workflows
topic in theWorkflows documentation.

Initiate items in STEP Workflows
This initiates any objects that the bulk update is performed on in the selected workflow, assuming that the objects
selected are valid for the workflow. To perform this action, select a workflow from the dropdown list and enter the
process note / background process note.

For more information on initiating items in a STEP workflow via bulk updates see theBulk Update Operations
for Workflows topic in theWorkflows documentation.
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Remove items from STEP Workflow
This removes all objects from one state in a workflow. Remove objects by selecting the workflow and entering in a
process note for the background process that takes place.

For more on how to remove items fromSTEPWorkflows using bulk updates, see theRemove Objects From
Workflows topic in theWorkflows documentation.

Trigger STEP Workflow Event
This allows a user to move an task from one state to another state. This can be performed by selecting a workflow,
selecting the desired state in the workflow, and then choosing the event that needs to be triggered. A process note
can also be added.

For more on triggering STEPWorkflow events, theBulk Update Operations for Workflows topic in the
Workflows documentation.

Run Business Rule Operation for Bulk Updates
This runs a business rule on the selected objects. To run this business rule condition needs to be selected first, and
then a business rule action needs to be selected.When the bulk update is run, it will then evaluate the business
condition, and if it equates to 'true' then the selected action will take place.

Alternately, if there is not a condition that needs to be applied, this field can be left blank and only a business action
needs to be selected.
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Send Republish Event Operation for Bulk Updates
To perform this, a user will have to select a receiving processor to send the republished event to. It could be an
Event Processor, Outbound Integration Endpoint with an event queue, or an Event Queue directly. This option is
the same as selecting 'Republish' on one of the receiving processors. A republished event will then be sent to the
event queue of the selected processor for all objects in the bulk update.
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For more on republishing see theEvent-Based OIEP Forward, Rewind, Purge, and Republish topic in the
Outbound Integration Endpoints section of theData Exchange documentation.
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Set Name Operation for Bulk Updates
This sets the name of the object on which the bulk update is run. A user can either enter the namemanually, or
specify a function in the Function editor for naming the object.

See theUsing Function Editor topic within theAttributes documentation for more information on writing
functions.

To create a name using the editor, it is often attributes on an item that are concatenated tomake the name. For
example, in the image below there are two attributes that are populated that will be set to create the name of this
flashlight: 'Primary Color' and 'Brand Name'.
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By concatenating these two attributes together, it is possible tomake a name for this flashlight item.
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Set Object Type Operation for Bulk Updates
Changes the object type of the object on which the bulk update is run. You can select a specific object type or
construct a formula expression. Selected object type should be valid under the parent of current object.

See theUsing Function Editor topic within theAttributes documentation for more information on writing
functions.

To set the specified object type using a formula expression, the user needs to select the 'fx' button and then click
the ellipsis button to bring up the function editor. Enter in the appropriate function, and then proceed through the
editor. The example below there is an attribute on the item called 'Attribute C' that holds the ID of an object type.

When the bulk update is run, it uses the ID in the attribute to determine what object type the item should be set to.
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Monitoring Bulk Updates
When a user completes the Bulk Update wizard, theBackground process status dialog displays. This allows a
user to monitor the status of the bulk update that was created.

ClickGo to Process to display the Background Process tab where there is additional information about the
process execution.

Note: If one operation on an object or the auto approval of the object fails, changesmade by other operations are
rolled back, and the object is left as it was prior to the bulk update.

When the process has completed, the following options are available beneath theBulk Update Actions flipper at
the bottom of the Background Process tab.
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1. ClickSave to keep a copy of the execution report. This can be saved locally on a user's system.
2. ClickTruncate if not all lines in the execution report are needed. Upon selecting Truncate, a dialog will appear

allowing users to select which lines to dispose of, and how many lines to retain.
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3. ClickRelaunch Wizard to open theBulk Updatewizard again. The wizard openswith the same objects
selected and with the same operations specified as in the process that was just completed.

4. ClickBulk Update OK Objects if a pre-flight processwas run and a user wants to run a bulk update on the
objects that were processed without errors in the pre-flight process.

5. ClickSave Failed Objects to save the objects for which the bulk update failed. These objects can be saved as
a new collection. Note that this option will only be available if there were failed objects.

6. Click Impact Report to view a report of the errors that occurred during the bulk update process. This option will
only be available if objects failed during the bulk update.
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Scheduling Bulk Updates for Collections
Scheduling a bulk update with collections can be useful for a group of objects that need to be updated on a regular
basis. Additionally, should a user want to schedule a group of objects for a bulk update instead of performing it
manually, they can only do so using collections. An example of thismight be if a user knows that they need all
current accessory references removed at a certain time on a group of objects before they are to be implemented
into a workflow.

There are a few prerequisites that must take place before a collection is scheduled to run a bulk update.

1. A collectionmust first be created. More on creating a collection can be found in theCreating Collections topic
in the Getting Started / User Guide documentation.

2. A bulk update configurationmust be created. SeeRunning Bulk Updates in theBulk Updates
documentation for more on how to configure a bulk update.

The steps below explain how to schedule a bulk update using collections.

Scheduling Bulk Updates
If a user wishes to perform a bulk update on a collection at regular intervals, they can create a schedule that
applies to that particular collection. The bulk update is then automatically run at the scheduled time.

To begin, open the Schedule Bulk Update wizard by going to File > Bulk Updates > Schedule Bulk Updates.

Step 1 - Setup
On the first screen, specify the collection and the configuration that is needed.

1. Click the ellipsis button (…) to locate and select the relevant collection. If the collection selected is created using
the search criteria, and theRefresh before each run (Search Collections only) checkbox is selected, it will
refresh the collection based on the current data in the STEP system using search criteria, and execute the bulk
update operations. If the collection was created by going to File > Bulk Update > Run Bulk Update, then this
option will not be valid.

2. Click the ellipsis button (...) to locate and select the relevant configuration.
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3. CheckAuto approve changes if you want to place the updated objects in the approved workspace
immediately after the update.

4. ClickNext.

Step 2 - Preview
This screen shows an examples of the results of the update. ClickNext to continue.
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Step 3 - Schedule Process
In Step 3, create the time schedule. Select eitherNow, Later,Weekly orMonthly. The available options depend
on user selection. Select the options needed, and then clickNext.

Step 4 - Name Process
In the final step, enter a name for theSchedule Process and for theProcess. ClickFinish to complete the
wizard.
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Upon hitting Finish, it will give the user an option of going to the background process. If selected it will take the
user to the background process tab and display the background process.
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If the bulk update is scheduled, then it will show under 'Queued process'.
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